Online Giving not working with Safari v10
Incident Report for Kindrid
Resolved
A fix has been released. Online giving is fully operational again in Safari v10.
Posted 10 months ago. Feb 01, 2018 - 11:39 EST
Identified
The issue has been identified and a fix will be released soon.
Posted 10 months ago. Feb 01, 2018 - 11:34 EST
Investigating
We have found an issue with online giving using Safari v10 browser. While we investigate a fix, we recommend updating to the latest version of your web browser. We will post an update when we have more information.
Posted 10 months ago. Feb 01, 2018 - 11:22 EST