Deposit Delays
Incident Report for Kindrid
Resolved
All affected deposits have been successfully processed.
Posted 5 months ago. Jun 20, 2018 - 12:51 EDT
Monitoring
Our payment processor confirmed all pending deposits have been pushed and should be posting to the appropriate bank accounts by tomorrow at the latest.
Posted 5 months ago. Jun 19, 2018 - 14:44 EDT
Identified
Our payment processor has identified the problem and is working on completing all pending deposits through a manual push.
Posted 5 months ago. Jun 19, 2018 - 14:10 EDT
Investigating
We're experiencing a delay with deposits on/after June 15, 2018 where they are "Pending" for longer than usual for most churches. Our support team is working with our payment processor to identify the cause and push those deposits through.
Posted 5 months ago. Jun 19, 2018 - 09:24 EDT
This incident affected: Services (Gift Processing & Bank Disbursals).