Church Dashboard and Online Giving Outage
Incident Report for Kindrid
Resolved
The Church Dashboard and Online Giving via Give.Church are now working normally again.
Posted over 1 year ago. Nov 28, 2017 - 22:38 EST
Investigating
The Church Dashboard and Online Giving via Give.Church are currently unreachable. We're investigating the cause of the outage. Text Giving is still operational.
Posted over 1 year ago. Nov 28, 2017 - 22:14 EST